Announcement

Collapse
No announcement yet.

Monitor 22 heater troubleshooting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Monitor 22 heater troubleshooting

    Hello,

    I have a Monitor 22 heater which has been installed but has not been used in about 4 years.

    I turned it on today and it actually fired up and started heating for a while until it actually reset? and when it did so the burner LEDs were flashing together with the Time/Temperature setting.

    Any thoughts/comments on how I can troubleshoot this?

    Is there a manual that I can buy for learning more? I looked on eBay for Monitor 22 manuals, found nothing.

    Thank you!

  • #2
    You can download the manual from the Monitor dot com website.

    Comment


    • #3
      Thanks -- after reading this manual I figured it may be an overheating issue.

      Separately I see the heater comes up with 42 deg measured in the room which would imply that the thermistor is not connected properly? Can somebody confirm that this is the case as I was not able to find this in the manual but it came up in Google searches.

      Thank you

      Comment


      • #4
        The manual says the temperature sensing range is 42°F to 95°F. At 42° the thermistor should have a resistance of around 25K; at 77° it should measure 10K; at 95° it should measure about 5K. This is with the thermistor disconnected from the PWB. The manual also says the voltage across the Q connector on the PWB should be between 1.6V & 3.3V with the thermistor connected & the heater powered up. If the thermistor is disconnected, then the resistance across the Q connector would be more than 25K, so 42°.

        Comment


        • #5
          Originally posted by dantm View Post
          Hello,

          I have a Monitor 22 heater which has been installed but has not been used in about 4 years.

          I turned it on today and it actually fired up and started heating for a while until it actually reset? and when it did so the burner LEDs were flashing together with the Time/Temperature setting.

          Any thoughts/comments on how I can troubleshoot this?

          Is there a manual that I can buy for learning more? I looked on eBay for Monitor 22 manuals, found nothing.

          Thank you!

          Usually when this happens with my 422 it's because the flame rod has come in contact with the flame ring or soot has bridged between the flame rod and flame ring. If the flame ring is mushroomed or warped and making contact with the flame rod it will need replacing. If it's just soot between the rod and ring simply loosen the flame rod and move it around this will remove the soot. To help prevent this I took the flame rod out of my 422 and cut it right below the bent section and put it back in.
          Last edited by FordMan59; 12-16-2019, 11:17 AM.

          Comment


          • #6
            Listen carefully and watch the burn window before/while the heater shuts off. A knocking sound will indicate not getting fuel, if the flame looks good and it shuts off you likely have a flame rod/ ring problem like explained above. If the flame is weak or yellow you can have clogged holes in the pot and that can cause the flame to die. Just pay close attention to what is going on through the window.
            Last edited by rrob311; 12-17-2019, 11:55 AM.

            Comment


            • #7
              Thank you! I will take your advice and will report back!

              Comment

              Working...
              X